1

I am trying to add a PostGIS database a data store in my GeoServer installation but I keep getting this error:

Error creating data store, check the parameters. Error message: Unable to obtain connection: Cannot create PoolableConnectionFactory (Le type d'authentification 10 n'est pas supporté. Vérifiez que vous avez configuré le fichier pg_hba.conf pour inclure l'adresse IP du client ou le sous-réseau et qu'il utilise un schéma d'authentification supporté par le pilote.)

1
  • Did you try doing what the message suggests?
    – Ian Turton
    Aug 22, 2021 at 16:00

2 Answers 2

3

The JDBC driver in use does not support the new SCRAM-SHA-256 encryption, you'll have to change it back to md5, or try upgrading the PostgreQL JDBC driver.

See also: https://stackoverflow.com/questions/64210167/unable-to-connect-to-postgres-db-due-to-the-authentication-type-10-is-not-suppor

0

The solution in my case was the following:

I modified the pg_hba file located in: C:\Program Files\PostgreSQL\14\data\pg_hba, changing the connection method from "scram-sha-256" to "trust" on all lines.

enter image description here

1
  • This is an English language site. Please use English
    – Padmanabha
    Aug 16, 2023 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.