2

I'm trying to load data product of the indexed Open Data Cube dataset image through the Jupyter Notebook. In this I'm using Resourcesat-2 AWiFS Data. The method used is shown below:

import matplotlib.pyplot as plt
import datacube
dc = datacube.Datacube(app = 'my_app', config='C:/Users/Dell/datacube.conf')
list_of_products = dc.list_products() 
list_of_products

After this it showed the list of product but when I tried to load the Data product using following method:

ds_2019 = dc.load(product = 'AWiFS_21May19',
      longitude = (77.0, 78.0), 
      latitude = (27.0, 28.0), 
      output_crs = 'EPSG:4326', 
      resolution = (-0.00045, 0.00045)) 

print(ds_2019) 

It showed the following output:

<xarray.Dataset>
Dimensions:  ()
Data variables:
    *empty*

Can anyone please tell what's wrong here and how to load a particular data product in the notebook?

I am doing a local installation of Open Data Cube and indexed some datasets with PostgreSQL on a Windows 8.1 system.

2
2

Usually if you get an empty return, there is no data over your area of interest.

Try loading a dataset searching by extents, like this:

datasets = dc.find_datasets(product='AWiFS_21May19', limit=1)

data = dc.load(datasets=datasets, output_crs='EPSG:4326', resolution=(-0.00045, 0.00045))
1
  • 1
    Thank you so much.. It worked Aug 25 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.