4

I want to split a fairly large polygon with the Split Features tool from the Advanced Digitizing Toolbar in QGIS. However, I get an error:

No features were split: If there are selected features, the split tool only applies to those. If you would like to split all features under the split line, clear the selection.

I can confirm that no features are selected and that the polygon has a valid geometry. I am able to split smaller sections of the polygon (fewer nodes between splits) but not larger sections of the polygon.

Data sample available: http://www.filedropper.com/problempolygon
QGIS version: 3.18.1 (Windows)
CRS: EPSG:32718
Data source: Shapefile
Geom type: Multipolygon (Single parts)

Any suggestions on what the problem might be and how to fix it?

0

2 Answers 2

6

For me your shapefile with polygons seems to be okay. I checked it with the "Check validity".

Here is the recreated problem: problem

It appeared because basic usage-requirements were not met when working with the "Split Features".

So, there are several ideas on how to overcome it:

  1. Either the splitting line has to be drown beyond the geometry resolution_1

  2. or the splitting line has to snap vertices/segments of the geometry resultion_2

1
  • 1
    Solution 1 and 2 worked. Thanks
    – PyMapr
    Commented Aug 27, 2021 at 12:13
0

In case your feature consists of inner rings, make sure to use the "split feature" tool in such a way that it covers the entire feature.

For example: wrong use of split tool

and in the right case below: right use of split tool

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.