0

I've trying to georeference an orthomosaic from Phantom 3 (around 6 m error) using an orthomosaic from Phantom 4k rtk as reference. The former in epsg:32629, the latter in epsg:25829.
enter image description here
When working in QGIS 3.20.2 estimated residuals are in the magnitude of 10^6 or 10^7, which makes no sense. The same happens if I project the first tiff to 25829 before georeferencing. Using the Zoom to extent button you can see the new tiff is many kms away from the reference tiff, but nothing is visible in it (Zoom to layer gives a white window).
The issue arouse in a working project, but remains unchanged within a new clean project.
enter image description here
I tried with different transformation types, but the same happens, residuals change from around 5x10^6 to 8x10^7.
My system is in Spanish, but I also tried to change the decimal point to . in the system before opening 3.20. Same result.
Everything goes smoothly in 3.16, though, in the same computer, OS and with the same files and same control points (loaded from file). And it goes smoothly with different transformations, different number of points and when in my working project or clean project. I'm considering to report this as a bug, but I would like to be sure first that I am not skipping something obvious, or any change in how the georeferencer works.

1
  • The "x de origen" and "y de origen" values in the ground control point table do not make sense. They should present the pixel locations (x and y pixelt to the right and to the bottom from the top left pixel of the image). Have a look how the values are imported from the file into QGIS 3.16. Could you even share the file?
    – user30184
    Aug 31, 2021 at 8:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.