I have an area polygon with rocks on it i want to use difference to map the soft (ground, not rocks) cover. to do that i try using the (ftools) vector>geoprocessing>difference getting an empty difference layer. I tried performing this analysis both on windows and linux using shapefiles and sqlite.

a zipfile containing the data can be downloaded at:https://www.dropbox.com/s/s1lrepa95lwdm9e/stackexchange.zip

I have a few questions: 1. Can anyone tell me why? 2. Where can i find the qgis log so i might be able to figure this out 3. Is there an alternative to ftools to perform such analysis? 4. it seems to me that some of the ftools function dont work for me, does anyone know of a solution for that? 5. might this be somehow encoding related (some of the layers were produced in windows some linux)

OS: windows xp, linux ubuntu 12.04 qgis: 1.8

  • Please try to ask only one question per thread. It would be easier to vote for answers that way. Otherwise you might have answers that are both right and wrong. – R.K. Nov 13 '12 at 15:22
  1. Your data have some invalid geometries. Try correct it using Grass v.clean tools

  2. In QGIS, View > Panels > Log messages

  3. You can try use GRASS v.overlay with the "Not" operator. Doing it With SEXTANTE Toolbox is almost painless, you don't even need to convert the data to a grass DB. I tried with your data, and it seamed to create the correct result.

  • OK this is correct i had invalid geometries. – yair suari Nov 14 '12 at 8:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.