3

I have a QGIS 3 project with EPSG code 25832 where there are shapefiles and and PostGIS layers. I added a shapefile consisting of *.dbf, *.qix, *.shp and *.shx files. This shapefile was used in ArcGIS before.

There is an attribute table but no map appears in the map canvas.

0

1 Answer 1

4

There is missing a *.prj file that contains the projection (see also When are .prj files included with Shapefiles?). Go back to the data source to get this file.

If that is not possible, manually set the layer CRS (one of the few cases you actually should do that...): right-click layer/ Layer CRS / Set Layer CRS…. You have to guess, based on the nature of the data, which one is the correct one. If you now export/save the shapefile, a *.prj file will be generated.

9
  • setting the CRS manually doesn't help - I generated a *.prj file but this doesn't help either
    – geofee
    Commented Sep 3, 2021 at 7:12
  • after setting the CRS manually the shapefile is visible but doesn't overlay the other layers, it is depicted in another location
    – geofee
    Commented Sep 3, 2021 at 7:34
  • You have to find the correct CRS. Put a basemap (like OpenStreetMap form XYZ tiles) to see if it is located in the correct place. Maybe the other layer are misplaced, too? What region of the world, what extent does the file have? Can you share the file for testing?
    – Babel
    Commented Sep 3, 2021 at 7:37
  • I put OpenStreetMap and I see the file is located in another place. the other layers are placed well. The file should be placed in the region of Hannover, Germany and I use EPSG 25832.
    – geofee
    Commented Sep 3, 2021 at 8:16
  • So then it must be another CRS valid in the area of Hannover... Where does the data come from? Can you check there in what CRS the data was saved in?
    – Babel
    Commented Sep 3, 2021 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.