3

I am trying to georeference an image (about 50mb and 20000x20000px), and every time I move the image or add a point it reloads/updates the image in georeference window and it takes about 1 minute to reload. Is it possible to disable image reloading in georeference window at least on the add point operation?

0

1 Answer 1

2

With my test image with a comparable file size and resoultion (65 MB, see below), it takes max. a few seconds to reload in the georeferencer. So probably your problem has more to do with the performance of your machine then with QGIS. Changing to a faster computer could solve the problem.

The other solution would be: save a copy of your image with a reduced filesize with same resolution. Load this to Georeferencer, set your GCP Points there, save GCP Points. Then load the original image, load the saved GCP points and run transformation. With your filesize, this will take a while.

To reduce file size, use any image processing tool (like IrfanView), discard color information and convert/export/save as JPG file with smallest possible quality (0%), but keep the initial resolution. Based on the high resolution you have, you should still be able to identify the places on the image you want to use for the GCP points.

See the image below, comparable to your setting: left an extract of the original image (65.5 MB, 15288 px * 13158 px), right the reduced file size: same resolution, but only 2 MB! This will load much faster.

enter image description here

The output I generated with this method: a correctly georeferenced image enter image description here

2
  • Thanks for the advice, will try it. I have SSD, ryzen 1600x and 16GB of ram - don't think it is a slow pc
    – SERG
    Sep 5, 2021 at 11:27
  • Weird than that it takes so long to load
    – Babel
    Sep 5, 2021 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.