6

I have QGIS 3.20.2 installed. I just reinstalled everything with OSGeo4W, but the Processing plugin loading is too slow (3 minutes!). How else can I restore the loading speed of QGIS?

enter image description here

4
  • 6
    Did you try deactivating processing, restart abd reactivating it? Did you try a new, empty user profile?
    – Babel
    Sep 8 at 6:22
  • 1
    @Babel Indeed startup with new profile is fast. How can I inspect and fix my current profile? Sep 8 at 6:24
  • 2
    Try deactivating all plugins to see if that helps and if so, reactivate one by one to see where the problem occurs. Or use the empty profile and change it by making the settings/installations you want.
    – Babel
    Sep 8 at 6:27
  • 3
    @Babel Thanks a lot for your help, I found a lot of garbage *.model3 files in C:\Users\username\AppData\Roaming\QGIS\QGIS3\profiles\default\processing\models. After deleting this garbage, QGIS loaded in 6 seconds. Sep 8 at 6:38
7

A new empty profile solved the problem.

In my case, the problem was caused by a large amount of garbage files *.model3 in C:\Users\username\AppData\Roaming\QGIS\QGIS3\profiles\default\processing\models.

After deleting this garbage in my old profile, QGIS loads in 6-10 seconds.

1
  • 4
    Great! Good to know that not only plugins, but also such stuff can slow down QGIS.
    – Babel
    Sep 8 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.