1

Since upgrading to ArcGIS Pro 2.8 from 2.6, I am facing an issue with the Jupyter Notebook that fails to load and returns an error:

Failed to Load Notebook

enter image description here

What all I have tried:

  1. Tried opening the notebook from the Python command prompt it gives an error as DLL Load failed the specified procedure could not be found
  2. Tried cloning the default environment from the manage environment option in the Python package manager of ArcGIS Pro by Project tab>> Python>> Manage environments>> clone>> assigned new name and path as C:\Temp.
  3. Renamed the python folder from 'C:\Program Files\ArcGIS\Pro\bin\Python'
  4. Tried repairing the application from the control panel
  5. Renamed the ArcGIS Pro folder from C:\Users<computer name>\AppData\Roaming\ESRI, and C:\Users<computer name>\AppData\Local\ESRI
  6. Renamed the FLEXnet folder C:\ProgramData\FLEXnet.
  7. Renamed the ArcGIS Pro folder from the registry editor as well
  8. Tried adding exclusions in the antivirus software for ArcGIS Pro with the help of the IT team
  9. Also tried running it from the location C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\Scripts but reproduced the same error message
  10. Checked if there are any Python variables defined from the Environment variables settings

Any insights or suggestions on how to resolve this error?

2 Answers 2

0

When I'm going to give up, I tried to reboot the computer and it worked. You should really try this. Let me know if this works.

0

https://support.esri.com/en/technical-article/000022938 This may be something related to permissions and exclusions from your antivirus software.

1
  • 3
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Feb 9, 2022 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.