-1

I am trying to create a bird map. The symbols look like this on my map, the value is the label (s)

enter image description here

However, in my key they look like this

enter image description here

Is there a way for me to get the key to show the value as well and not just the symbology?

1
  • 2
    Welcome to GIS SE. You should add more information, otherwise we don't know what you have and what you've tried. You have a point layer? The symbology is an SVG or a symbol created from attribute values? What do you mean by "key"? What you want should look like the S image or the Skylark image? There is a lot unclear in your question.
    – Babel
    Sep 15, 2021 at 15:41

3 Answers 3

3

You can add a Font Marker as a symbol layer and set a data driven override, e.g. left ("name",1):

enter image description here

In the legend, double click the entries, activate custom symbols (see last screenshot), select again the font marker and manually introduce the corresponding character (data driven override here does not work for me):

enter image description here

Activate custom symbols, then click on the symbol to make the settings:

enter image description here

0
1

Set a label with the expression: left(yourfieldname, 1) and:

enter image description here

0

Have a look at the "Text on Symbols" area in the "Legend" tab of the layer properties - especially the button "Set Labels from Expression" (see screenshot).
I think, this might be the solution for your problem.

Screenshot

Not the answer you're looking for? Browse other questions tagged or ask your own question.