2

I'm trying to use MOLUSCE Plugin for prediction of Land use expansion, I prepared and added the layers required for it but at 3rd step that is 'Area Changes' when I try to 'Update Table', ValueError keeps occurring.

ValueError: The truth value of an array with more than one element is ambiguous. Use a.any() or a.all()

I'm new to QGIS and don't know Python either, could anyone suggest a solution to this problem?

2
  • Did you define no data value before using molusce? Commented Sep 17, 2021 at 0:12
  • how do we define NoData value? By setting NoDataValue=0? I did that as well but error is still there. Commented Sep 17, 2021 at 6:59

1 Answer 1

2

I was using 2.18.28 and I faced a similar problem. I installed 2.18.15 (on another pc) and it worked... you can try deleting and installing 2.18.15...

1
  • yes I was using 2.18.28 as well and then I installed 2.18.26 and the error was gone but now my simulated map shows almost same map as the final one, I think it has something to do with the training of model. I have tried various sample size and number of iterations for ANN with Random Sampling but no significant changes appear. Do you know how could we find the optimum training sample mode and size? Commented Sep 24, 2021 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.