1

I have two GDAL installation, one from the OSGEO4W installer and one from Tamas Szekeres’ Windows binaries. I set the necessary variables according to the article.

I open Powershell and ran gdalinfo --version and got many errors like this

ERROR 1: Can't load requested DLL: C:\Program Files\GDAL\gdalplugins\gdal_BAG.dll 193: %1 is not a valid Win32 application.

Also, the GDAL version returns but it's an old version GDAL 1.6.0, released 2008/12/04. The GDAl in my OSGEO4W shell is GDAL 3.3.1, released 2021/06/28 and GDAL 303 Command Prompt GDAL 3.3.2, released 2021/09/01. I use a 64-bit device.

enter image description here

My GDAL system variables are set accordingly also and C:\Program Files\GDAL is added to my Path system variable.

enter image description here

1 Answer 1

0

Solved. Apparently, in my Path system variables, there was a directory pointing to the GDAL 1.6 file. I removed it, removed also the 3 GDAL variables stated in the article. Added those 3 variables again and Powershell now says GDAL 3.3.2, released 2021/09/01.

https://sandbox.idre.ucla.edu/sandbox/tutorials/installing-gdal-for-windows

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.