ArcMap for Desktop. No internet connection.

Two sets of lines (both in a file geodatabase). I want to get the points where they intersect. I use the intersect tool with both sets of lines as inputs and the output set to "point". Works for hundreds of thousands of crossing lines, but for some reason this one single pair of lines fails to produce an intersection point even though when I zoom in on the lines it is obvious that they intersect. Any general advice for what to even look for?

Things I tried based on the help below.

Check geometry returned empty tables for both sets of lines, suggesting everything is good to go.

The vertices of the lines are normal.

Exporting the data to another file and then using those new files with intersect did not make a difference.

I tried to edit the vertices of one line to make it snap to the other line, but when I hit the "finish sketch" button, save edits, and stop editing, the line returns to where it was before I edited it.

I just went in a added the points manually. I only had to do three of them, otherwise it wouldn't be feasible.

  • I'd try with shapefiles and see what happens.
    – FelixIP
    Sep 30, 2021 at 2:47
  • Linear intersection can be weird if the intersection point is below the X/Y tolerance and/or scale. Without SpatialReference properties and Well-Known Text of the geometries involved, it's hard to tell what is happening.
    – Vince
    Sep 25 at 3:51

1 Answer 1


Might be multi-part or corrupted geometry? Go into edit mode and select it and study it's vertices order. Also run check geometry tool on your data.

I would try to select the offending lines export those into a new dataset and try the intersection again on that subset? If that works it would suggest a corruption or anomaly in the dataset (e.g. corrupted spatial index or XY tolerance issue)

Finally what is source data source format? If it is a shapefile, import into a file geodatabase this often resolves precision issues in the data, especially if the shapefile has been generated by some other software that does not conform to ESRI standards.

  • Something strange happens when I try to do that. No matter where I click it selects one of the lines and not the other. And if I draw a box to get the other line and exclude the first line, it selects both....
    – PencilBox
    Sep 29, 2021 at 15:40
  • Wow, something else really strange is happening. Every time I pan around the map, a new point from a different layer is generated in the top left corner of the map and sticks there when I pan again, leaving a trail of green markers......... this is so odd.
    – PencilBox
    Sep 29, 2021 at 15:42
  • Check Geometry returned empty tables on both sets of lines.
    – PencilBox
    Sep 29, 2021 at 15:49
  • So I viewed the vertices of the lines and they indeed seem to be in order. The first line clearly runs between the vertices of the second line.
    – PencilBox
    Sep 29, 2021 at 15:53
  • The panning issue could be a hardware issue? See update to my answer
    – Hornbydd
    Sep 29, 2021 at 15:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.