I have put together a map using the British OS Strategi data set which is pretty densely detailed. It is surveyed at 1:250,000 and so contains roads down to track level, rivers, villages, railway lines - you name it. There's a lot of data.

When I try and export an image version of the map (at about 1m x 1m), I always get an 'Exception: bad allocation' error. This happens when I try to export as a raster image or PDF. I have tried printing to a PDF generator (CutePDF) but the same thing happens. The print spooler shows the file size at 1.6Gb.

I am running QGIS on a dual core 2ghz Windows 8 system with 4Gb of RAM. Is it just a case of the file being too big? Is there anything I can do? Or is there an alternative, free GIS package that would do a similar job?

  • I guess you've already tried reducing the resolution set for the exported image? Perhaps it might be worth trying with a resolution of 150 dpi (or even 96 dpi). – nhopton Nov 17 '12 at 13:33
  • I need the image to be printable with reasonable quality for a wall map, so not really an option. – ElendilTheTall Nov 17 '12 at 14:26

There is a known bug in printing large formats on Windows systems:


If the hints given there won't help you, you can install a 64bit linux system, or have to wait until the bug is fixed.

  • Is the issue with windows or 32 bits? Obviously Windows 8 is 64 bit, but is Windows QGIS? – ElendilTheTall Nov 17 '12 at 8:42
  • No, QGis binaries for Windows are still 32-bit, but run on 64-bit Operating systems. – AndreJ Nov 18 '12 at 14:34
  • I've installed a 64-bit version of Ubuntu and get the same problem - it appears to be just too much data. Disappointing. – ElendilTheTall Nov 22 '12 at 9:42
  • Have you checked "export as raster"? This breaks exporting in large formats for me. So better leave it unchecked. – AndreJ Nov 22 '12 at 17:24
  • No, unchecked. I've also tried printing to a PDF and exporting as a raster image, no dice. – ElendilTheTall Nov 23 '12 at 12:12

I tried the two methods suggested above and neither helped me. After 1 hour of switching off and on layers, I finally found that going to:

Properties->Labels (depreciated) -> Buffer labels

and switching off buffering solved the problem.

Even a few polygons with just a few text labels generates file sizes of 10's MB which crash my network printer! I think this should be filed as a bug, though it does say "deprecated" so maybe this will be fixed in future versions. I am using :

QGIS version 2.2.0-Valmiera QGIS code revision c3a2817

On Windows 7, 64 bit. Downloaded 02.06.2014

  • Just move from deprecated labeling to new labeling. The deprecated version is only there for backwards compatibility with old QGIS projects. – underdark Jun 6 '14 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.