1

I'm using QGIS version 3.16.4 Hannover and since I downloaded it, I haven't been able to create a shapefile layer or use any editing tools. When i try to make a shapefile it gives an error saying:

Failed to create layer: failed to create file line.shp: read-only file system.

So I assume that I have to change the file system from read-only, into something I can edit. However I can't find anything concerning this. I tried different file coding, geometry and type. I use a map of The Netherlands and I've tried both WGS 84 and Amersfoort/ RD New. I don't have much experience with QGIS. How can I fix this?

2
  • 3
    Show us the file path. QGIS often defaults to saving things in a read only system folder
    – Encomium
    Commented Oct 4, 2021 at 15:26
  • 2
    Also what operating system are you using? Is this your computer or a work / network computer ? See also: gis.stackexchange.com/questions/282434/…
    – GISHuman
    Commented Oct 4, 2021 at 21:09

1 Answer 1

2

Change the path of where you're saving the file. It's very likely that you are trying to save the file in a read-only system folder.

Press the button highlighted in blue:

enter image description here

You'll likely see that the default path is in a read-only folder:

enter image description here

Just select a path to your Documents or somewhere else where you have full read/write access.

2
  • Ah okay, where can i find this?
    – Britt
    Commented Oct 4, 2021 at 15:37
  • Check updated answer with screenshots. I assume you're using Windows? I added WIN10 as your OS as a tag. Please change that if you're running on a different OS.
    – Encomium
    Commented Oct 4, 2021 at 15:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.