2

I am trying to run the "GPX to Features" tool in ArcMap 10.8 to convert tracks from a handheld Garmin device.

Here is how I ran the tool:

inGPX = "C:/Users/Admin/Desktop/EMR/Field_10_27_2021/Garmin/Raw/DB_2021_09_29a.gpx"
outFC = "C:/Users/Admin/Desktop/EMR/Field_10_27_2021/Garmin/Track_pts/DB_2021_09_29a_trkpts.shp"

arcpy.GPXtoFeatures_conversion(Input_GPX_File=inGPX, Output_Feature_class=outFC)

Tool Screenshot

I keep getting the following error:

Traceback (most recent call last):
  File "c:\program files (x86)\arcgis\desktop10.8\ArcToolbox\Scripts\GPXtoFeatures.py", line 260, in <module>
    gpxToPoints(gpx, outFC)
  File "c:\program files (x86)\arcgis\desktop10.8\ArcToolbox\Scripts\GPXtoFeatures.py", line 36, in gpxToPoints
    tree = ElementTree.parse(gpxfile)
  File "<string>", line 62, in parse
  File "<string>", line 38, in parse
ParseError: unbound prefix: line 1, column 1085

Failed to execute (GPXtoFeatures).

This seems like an issue with the script for the tool itself, which I have not edited. I am using the tool "as is" from the default toolboxes in ArcMap. I use this tool often and it worked a few days ago. I am not familiar with Python.

What does this error mean and what can I do to fix it?

2
  • 2
    Can you share how to the tool was executed to help others answer? A screenshot of the filled out GPX-to-Features tool, or a copy of the code snippet itself (right click the tool in your history window "Copy as Python snippet")
    – Keggering
    Oct 6, 2021 at 20:16
  • Is the input data correct(try checking in notepad ++)? en.wikipedia.org/wiki/GPS_Exchange_Format, By any chance, do you have DataInteroprability? Oct 7, 2021 at 8:30

1 Answer 1

2

Odds are the GPX is malformed, or it has something in it that the GPX to Features tool does not understand. There is very little that you can do to fix this. You'll either need to submit to Esri Tech support (assuming it's a tool problem), OR import your GPX file into other software and confirm it's well formatted.

I'd suggest just opening up arcgis.com map viewer and dragging it in: does this work? If so, then submit to tech support.

Since you mention Garmin, a quick story -- I was the original author of the GPX to Features tool at Esri. I created the opposite (Features to GPX) as a sample. Dozens of people complained that creating a GPX file from the sample never worked with Garmin basecamp. Someone was eventually able to figure out Garmin wanted some extra bit of information or something along that line - it was very strange. I just bring it up as it could very well be a Garmin + tool specific problem.

1
  • I think the GPX is corrupted because the tool worked on other GPX files from different Garmins
    – Emily R.
    Oct 14, 2021 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.