0

I'm trying to import either OSM (from XYZ tiles) or a WMS as a basemap. While my shapefiles map just fine, neither the OSM nor the WMS basemap appears in the window despite appearing in the legend. They do not show up even at scale 1:250000 or by clicking on Zoom to layer.

These are some of the fixes I have tried, but none have worked:

  • Changing project CRS (ESPG:4326) to OSM CRS (ESPG:3867) and vice-versa
  • Setting layer scale visibility
  • Resetting network cache
  • Manually connecting OSM with a link under XYZ tiles
  • Creating a new user profile

I am using QGIS version 3.4, although I cannot check the exact version information as I am faced with an error message "unable to get current version information from server". I'm not sure if this is relevant to my problem.

EDIT: This is what my display window looks like enter image description here

5
  • 2
    Can you see the basemaps if you add them thanks to the QuickMapServices plugin ?
    – wanderzen
    Oct 8, 2021 at 8:52
  • Are you sure that the OSM or WMS layers are on the top - thus not covered by another layer? Can you add a scrrenshot, showing your map canvas and layer panel?
    – Babel
    Oct 9, 2021 at 21:29
  • @Babel it's been added. The layers are not covered
    – lizard
    Oct 11, 2021 at 12:23
  • 1
    The "unable to get current version information from server" message could be a sign that QGIS dont have full internet access (or very slow), that may explain map not appearing
    – J.R
    Oct 11, 2021 at 12:55
  • What are you using to add the OSM layer? I use the QuickMapServices plugin with "OSM Standard" and have success. Are you using a particular URL for a layer with AddLayer/Add WMS/WMTS ? What URL are you using to access the OpenStreetMap tileserver?
    – Dave X
    Oct 26, 2021 at 18:23

1 Answer 1

1

You coordinates field shows 142.7515,86.5322 - this is out of the map canvas. Pan the image or (even better) type 0,0 to the status bar at the bottom left of your QGIS window and type ENTER - the map canvas will be centered on Null island and you should see the basemap.

enter image description here

2
  • Sorry, I should've chosen a better picture. Using the coordinates (0,0) yields nothing, it is still a blank window
    – lizard
    Oct 11, 2021 at 13:23
  • Type world to the Coordinate field at the bottom of your QGIS window to load the pre-installed world map: does it show up? Have you close and reopened QGIS, started a new project?
    – Babel
    Oct 11, 2021 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.