3

I have a QGIS project with two ArcGIS Image Server layers that contain orthophotos (from 2018 and 2021 respectively). The project has a print layout that is controlled by an Atlas. When I turn on the 2018 orthophotos and export the Atlas as images, the images export correctly. When I turn off the 2018 orthophotos and turn on the 2021 orthophotos, the tiles that are saved when I export the Atlas as images are empty.

After closely inspecting the [Layer Properties][Information] tab for both layers, the only difference I see is that the 2018 [layers][defaultVisibility] tag is true for the 2018 orthophotos and false for the one from 2021.

Has anyone experienced an issue where exporting an Atlas as images results in blank tiles, and if so, were you able to correct this?

Is it possible that the [defaultVisibility] tag on the webserver is affecting the export, and if so, is there any way I can override this from my end if the ArcGIS server instance is not mine?

1

2 Answers 2

4

Sometimes I experienced empty tiles or missing tiles.

When you export the atlas, there is an export option to "Enable antialiasing". This help to download the tiles before any export and that fixed the problem for me. Hope it will solve your issue too.

2
  • That sounds like a weird bug, can you make a minimal reproducible example that shows this so QGIS can fix it? Commented Oct 12, 2021 at 19:03
  • This is not due to QGIS but it is due to tile server. When you do an atlas you make to many call in a short period of time and the export is done with some tile missing or no tile at all. It depend on server policy and speed (as tile server are not made for this purpose). To get a reproducible example make a 8 k square export and activate 2 or 3 tile layer with transparency you will get missing tile. If no missing tile then you can include it in an atlas of 10 points. Commented Oct 13, 2021 at 7:44
1

I had a similar issue once and it was related to the printing resolution. You can try lowering the DPI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.