2

I'm using GDAL 3.3.1 with all the necessary variables already setup.

I'm reprojecting a vector layer using ogr2ogr ogr2ogr -t_srs EPSG:32651 test.shp new_layer.shp and an error says

ERROR 1: PROJ: proj_create_from_database: SQLite error on SELECT name, coordinate_system_auth_name, coordinate_system_code, geodetic_crs_auth_name, geodetic_crs_code, conversion_auth_name, conversion_code, area_of_use_auth_name, area_of_use_code, text_definition, deprecated FROM projected_crs WHERE auth_name = ? AND code = ?: no such column: area_of_use_auth_name

ERROR 1: Failed to process SRS definition: EPSG:32651

A similar question was asked already but not entirely the same with my problem “Cannot find proj.db” and "ERROR 1: PROJ: proj_create_from_database: cannot build geodeticCRS 4326" errors

5
  • 1
    See comment in gis.stackexchange.com/questions/383883/… You're likely using a PROJ < 8 library with a proj.db from PROJ 7.2 or 8. Check PROJ_LIB.
    – user30184
    Oct 14 at 19:42
  • Thank you! I hope the fix is an easy one.
    – BallpenMan
    Oct 15 at 12:05
  • Do you know how to solve this? I just upgraded my proj to 8.1.1 via OSGEO4W installer (proj.org/install.html) and the same error shows. The link you sent me does not have a solution but rather only the problem. Thank you.
    – BallpenMan
    Oct 15 at 12:36
  • Nevermind. Solved it thanks to this gis.stackexchange.com/a/394320/146811
    – BallpenMan
    Oct 15 at 12:58
  • 1
    You must have also an older version of Proj somewhere in your system. Proj 8 does not query the area_of_use_auth_name field.
    – user30184
    Oct 15 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.