I'm trying to perform a supervised classification using i.class. I'm then using i.maxlik, but this is returning the following error:

GRASS 6.4.3svn (India_01):~ > i.maxlik group=test_group@test subgroup=test_group sigfile=test_sigfiles1 class=test_results1
ERROR: Unable to read signature file <test_sigfiles1>

I'm not sure what other information I should provide. Can anyone suggest the possible reasons for this error? I've tried using i.cluster to generate an unsupervised signature file, and i.maxlik reads this perfectly well.

  • That's weird. Are you sure the output sigfile from i.class is named test_sigfiles1? Just checking..
    – user8723
    Nov 18 '12 at 19:20
  • Yes - checked and double checked. If the file name is entered wrongly the error is 'Unable to open signature file <wrong filename>, so there seems to be something wrong with the file itself.
    – si_2012
    Nov 18 '12 at 19:45
  • Did you resolve this issue? What is the console response/output after the completion of i.class? Can you provide the signature file itself? Jan 5 '13 at 1:58
  • Note: This is a pretty old question from GRASS GIS 6!
    – markusN
    May 30 '17 at 23:30

I've had this error from i.cluster, so not exactly the same as you, but I've fixed it by changing the options of my clusterring. In my case, I've set the minimum number of pixels per class (min_size) to be too high in comparaison to the number of class/pixels in my limited calculation region. So I think people experiencing this error should play around there different clustering options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.