0

I have been going through LiDAR processing tutorials for R and was successfully able to get through this one by NEON about 4-5 months ago: https://www.neonscience.org/resources/learning-hub/tutorials/structural-diversity-discrete-return

I recently reopened the file and tried to run the same functions with the same data on my MAC but am running into multiple functions being listed as deprecated, starting with readLAS. I was able to use read.las as a work around function. I then had issues getting plot to work with XQuartz but was able to get plot3d() from the rgl package to work. After that I wasn't able to progress.

I tried to see if it was my computer but using the R Studio cloud and was able to get readLAS to load the data without needing read.las

I wanted to see if this was a widespread issue with this package on Mac OS, with the R version (4.1.1), or perhaps the package since I was able to run it just fine a few months back on the same system, though with an earlier R version.

Any suggestions?

2
  • It does not work is not enough to help you.
    – JRR
    Oct 19, 2021 at 20:00
  • CRAN binaries are corrupted. #485 #491
    – JRR
    Oct 19, 2021 at 21:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.