1

I'm running QGIS on windows 10 and have a problem running GRASS and SAGA tools. The problem appears only when using QGIS 3.20 or 3.18. Using QGIS 3.16 on the same machine, using the same dataset and applying the exactly same tool with the same settings, it works perfectly. So there seems to be an issue with the installation.

The problem arises with interpolation tools (v.surf.rst, Saga Multilevel b-spline interpolation), but not only - so the problem does not seem to be tool specific and not parameter specific (it runs in 3.16 without problems).

Looking at the Log Messages, in the tab Plugins it have the following messages what makes me think that there is a problem with the installation path.

The sequence saying Das angegebene Modul wurde nicht gefunden means The specified module could not be found:

2021-10-28T21:20:49     WARNING    Failed to load C:/PROGRA~1/QGIS32~1.0/apps/qgis/plugins/grassplugin7.dll (Reason: Cannot load library C:\PROGRA~1\QGIS32~1.0\apps\qgis\plugins\grassplugin7.dll: Das angegebene Modul wurde nicht gefunden.)
2021-10-28T21:20:49     WARNING    Failed to load C:/PROGRA~1/QGIS32~1.0/apps/qgis/plugins/grassprovider7.dll (Reason: Cannot load library C:\PROGRA~1\QGIS32~1.0\apps\qgis\plugins\grassprovider7.dll: Das angegebene Modul wurde nicht gefunden.)
2021-10-28T21:20:49     WARNING    Failed to load C:/PROGRA~1/QGIS32~1.0/apps/qgis/plugins/grassrasterprovider7.dll (Reason: Cannot load library C:\PROGRA~1\QGIS32~1.0\apps\qgis\plugins\grassrasterprovider7.dll: Das angegebene Modul wurde nicht gefunden.)
2021-10-28T21:20:49     INFO    Loaded OpenLayers Plugin (package: openlayers_plugin)
2021-10-28T21:20:50     INFO    Loaded QuickOSM (package: QuickOSM)
2021-10-28T21:20:51     INFO    Loaded QuickMapServices (package: quick_map_services)
2021-10-28T21:20:51     INFO    Loaded DB Manager (package: db_manager)
2021-10-28T21:20:51     INFO    Loaded MetaSearch Catalog Client (package: MetaSearch)
2021-10-28T21:20:54     INFO    Loaded Processing (package: processing)

The files mentioned can be found in the folder, see screenshot:

enter image description here

How can this issue be solved?

1
  • 1
    Seems to be the stand-allone install, you can try the osgeo4w installer instead.
    – eurojam
    Oct 29, 2021 at 5:57

1 Answer 1

1

After further research and a closer look to my installation files, it turned out that indeed in the QGIS 3.20 installation folder C:\Program Files\QGIS 3.20.0\bin, there was only the qgis-bin.exe file, the qgis-bin-g7.exe was missing. The QGIS 3.18 installation contained both files, but I somehow missed to start qgis-bin-g7.exe, but had the shortcut icon point to the qgis-bin.exe file. Changig it to qgis-bin-g7.exe solved the issue.

As for 3.20, I don't know why qgis-bin-g7.exe was missing - probably as mentioned by @eurojam an issue connected to the stand alone installation. I now installed QGIS 3.22, so repairing the 3.20 installation is obsolete.

Here, I also have only C:\Program Files\QGIS 3.22.0\bin\qgis-bin.exe, but now the GRASS and SAGA tools work as they should. I used the Standalone installers (MSI) from OSGeo4W packages.

1
  • Similar solution worked for me: when I start QGIS from the startmenu shortcut, SAGA and GRASS don't load, but if I start the exact same .exe that the shortcut is pointing to, it works.
    – miln40
    Jun 28, 2022 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.