2

I'm trying to access imagery from a WMTS server, but after connecting I get the following error:

Invalid Layer: WMS provider Cannot calculate extent Raster layer Provider is not valid (provider: wms, URI: crs=EPSG:3857&dpiMode=7&format=image/png&layers=3inch_Orthos&styles=default&tileMatrixSet=GoogleMapsCompatible&url=https://services.sanborn.com/geo_caches/312021386_Solano_County_Oblique/wmts.xml

I was told that this server requires no authentication. The only instructions I have for using the server pertain to Autodesk Civil 3D, which I don't have, so I'm trying to access the imagery via QGIS. I'm not GIS-fluent, so I'm kind of stumbling around in the dark, but thought I'd post the problem and see if anyone here sees a clueless newbie problem that's easy to remedy.

P.S. A colleague says he was able to use the imagery from this server using both Autodesk Civil 3D and ESRI ArcMap, but was not able to get it to work with QGIS.

4
  • Welcome to Geographic Information Systems! Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Your questions should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. Please check out our short tour for more about how the site works
    – Ian Turton
    Oct 30, 2021 at 8:28
  • Confirmed, Civil 3D 2022 can access it but QGIS 3.18.2 can't. I dunno why.
    – Pointdump
    Oct 31, 2021 at 22:56
  • I get the same error with QGIS 3.22 on ubuntu. Invalid Layer: WMS provider Cannot calculate extent Raster layer Provider is not valid (provider: wms, URI: crs=EPSG:3857&dpiMode=7&format=image/png&layers=3inch_Orthos&styles=default&tileMatrixSet=GoogleMapsCompatible&url=services.sanborn.com/geo_caches/312021386_Solano_County_Oblique/… The issue reports I found with this error didn't seem to be relevant for the version I was running. github.com/qgis/QGIS/issues/19037 and issues.qgis.org/issues/10634
    – elil
    Nov 8, 2021 at 3:56
  • This isn't a legitimate answer because it doesn't address the problem and error but it is a work around that can allow it to work another way. The related questions to the right gave me the XYZ tile idea (gis.stackexchange.com/questions/178404/…). Reading the xml file and adding an XYZ tile source in QGIS of services.sanborn.com/geo_caches/312021386_Solano_County_Oblique/…{Z}/{X}/{Y}.png seems to work. It doesn't look like 3 inch imagery through this method of access.
    – elil
    Nov 8, 2021 at 5:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.