3

In QGIS 3.16.12 I have previously inserted survey location points by adding a delimited text layer (clicking the correct buttons and setting x and y as long and lat).

Though now, when uploading the same CSV file, using the same methods, the file appears to have a different geometry to that of a point file (points don't show on the map, I cannot change symbology or zoom to layer, etc).

All the field types also seem to be Qstring (where normally, QGIS detects my different field types). I have attached a screenshot below.

enter image description here

I believe I've done everything as I normally would, but the CSV file is not showing up with the points on the map. As it has worked for me before, could this be a problem with QGIS, or am I missing something?

enter image description here

7
  • Welcome to Geographic Information Systems! Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Your questions should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. Please check out our short tour for more about how the site works
    – Ian Turton
    Nov 5 '21 at 16:56
  • please show us an example of your points - most likely error is that the projection is wrong
    – Ian Turton
    Nov 5 '21 at 16:57
  • @IanTurton, thank you for your reply :) I have attached an image of my points, I am still experiencing the same problem and am not sure why. I have even updated my version of QGIS. Nov 8 '21 at 9:12
  • What CRS are you wanting to use? 27700 or 4326? Have you tried adding the XY as Easting Northing?
    – Joe Be
    Nov 8 '21 at 9:16
  • 2
    (With geometry CRS set to 27700 in the Points from Delimited text tool )
    – Joe Be
    Nov 8 '21 at 9:22
2

As you have lat/lon values, stick to CRS EPSG:4326. However, uncheck DMS coordinates box and make sure X-field (Long) and Y-field (Lat) are set to the right column name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.