0

enter image description hereI am using ArcMap 10.4.1 and the Raster Calculator to subtract polygons of clouds, land etc from my DEM. I use the statement:

con(isnull, Cloud, DEM) 

and set the processing extent to environments of input because otherwise I do not get me whole DEM back.

Every time I do that though, the extracted cells do not match with the extent of my polygons anymore. There is always a shift of a few meters. Cell size is same for both.

Where is the problem?

3
  • If I do not set extent to Uniof in inputs, the extent extracted is the same as the polygon
    – Student
    Nov 6, 2021 at 8:58
  • 1
    Add a supporting screenshot. Nov 6, 2021 at 9:16
  • 3
    There are no such functions as con or isnull, your expression should never have even been able to run. If you're going to ask questions here, post exactly what you did, don't approximate. There is Con and IsNull however. Note IsNull is a function and you pass it something to test for null values. Your expression should look like Con(IsNull(DEM), Cloud, DEM). Your cloud polygons are getting converted where the centre of a pixel is overlapped by the polygon. You can't mask part of a pixel.
    – user2856
    Nov 6, 2021 at 12:41

1 Answer 1

0

To avoid nulls/blank cells, you may also want to check that the layer projections and units of Cloud and DEM match. Setting a snap raster also helps make the cells line up properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.