6

My edit toolbar became disabled while I was editing a layer in QGIS. I have closed the window and opened it again to edit, but it is still disabled.

4
  • What version of QGIS?
    – Fezter
    Nov 22 '12 at 4:45
  • Which version you are using ?? I am using 1.8.0 & its working fine for me..
    – Sunil
    Nov 22 '12 at 8:23
  • What sort of layer were you editing? Shapefile, PostGIS, something else? Nov 22 '12 at 15:37
  • Keep in mind that the layer to be edited must be selected in the layer list.
    – Scro
    Dec 1 '13 at 12:52
5

Maybe too obvious an answer, but it's what I needed when googling for this so...

"All editing sessions start by choosing the enter image description here 'Toggle editing' option"

"By default, QGIS loads layers read-only: This is a safeguard to avoid accidentally editing a layer if there is a slip of the mouse. However, you can choose to edit any layer as long as the data provider supports it, and the underlying data source is writable (i.e. its files are not read-only). "

https://docs.qgis.org/2.18/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html#digitizing-an-existing-layer

1
  • And to spell it out even further (my problem): "as long as the data provider supports it, and the underlying data source is writable" - I was importing a geojson file, and could not enable edit mode until, at this hint, I right-clicked the layer and saved it as a separate file (which created a new, editable layer).
    – Izkata
    Aug 2 '18 at 20:21
3

Had the same problem. In my case I had a Shapefile imported as Layer and defined a "Filter" on this Layer. Clearing the filter rule enabled the "Edit Button" again!

2

I had that problem too. I was trying to edit some MapInfo TAB files but even the 'Toggle editing' option was disable. Then I translated my files into Shapefile and then it worked.

1

I had the same problem with one particular shapefile (maybe it was protected by its vendor). My solution was to select all features and save the selection as a vector file (i.e. new shapefile) - in the "Layer" section of QGIS 2.2.0 top menu. The new shapefile layer is editable.

0

Do not browse your layer from the zipped folder! First unzip the folder, then browse your layer from the unzipped folder. Now toggle editing tool should work properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.