1

Following the recent PSA recommending users to upgrade from 3.16.12 to 3.16.13 (link), I've been having trouble accessing my plugins and Python console ever since upgrading.

I've done some digging and found that 3.16.13 uses python version 3.9 while 3.16.12 uses Python version 3.8. My OS is windows 7 which supports Python 3.8 but not 3.9, which was the initial issue I assumed which was causing QGIS to say that there was no Python support.

I've since done a rollback to 3.16.12 (by uninstalling 3.16.13 and reinstalling 3.16.12) but I still see the same problem. I've tried version 3.16.11 and also see the same issue. This is strange because I did not have this issue when I was using version 3.16.12 and I am unsure how to fix it. I could try installing the last long term release version which was 3.10 but I would prefer the newer one for its added features.

Also I am unsure what is the difference between the old .exe installers and the new .msi installers

No Python Support

Update: I have since installed QGIS version 3.10.11 and I am able to access plugins and the Python console again. I am still unsure as to what was causing the issue outlined in the third paragraph. I do note that for version 3.16 I tried both the .msi installers and the .exe installers and found that the .msi installed QGIS had the Python issue and the .exe installer had a different issue where the installer says the program was installed but Windows is unable to find it in it's list of programs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.