1

trying to use tegola on my local and the viewer page there is nothing showing up just this screen

enter image description here

here is my config file

[webserver]
port = ":9090"

Access-Control-Allow-Origin = "*"
Cache-Control = "no-cache, no-store, must-revalidate"

[cache]                     # configure a tile cache
type = "file"               # a file cache will cache to the local file system
basepath = "/tmp/tegola"    # where to write the file cache

# register data providers
[[providers]]
name = "test"   # provider name is referenced from map layers
type = "postgis"        # the type of data provider. currently only supports postgis
host = "hostess"      # postgis database host
port = 5432             # postgis database port
database = "db"     # postgis database name
user = "postgres"         # postgis database user
password = "doubtit"           # postgis database password
srid = 4326             # The default srid for this provider. If not provided it will be WebMercator (3857)

  [[providers.layers]]
  name = "school"
  tablename = "usa.schools"  # sql or tablename are required
  geometry_fieldname = "geom"
  id_fieldname = "name"
  srid = 4326  
  
  [[maps]]
    name = "locations"

  [[maps.layers]]
  provider_layer = "test.school"

and the command to start it

tegola serve --config=config.toml
2021-11-12 16:27:47 [INFO] root.go:61: Loading config file: config.toml
2021-11-12 16:27:47 [INFO] config.go:306: loading local config (config.toml)
2021-11-12 16:27:48 [INFO] providers.go:82: registering provider(type): test (postgis)
2021/11/12 16:27:48 observers.go:16: none: map[]
2021-11-12 16:27:48 [INFO] server.go:94: starting tegola server on port :9090

I've tried this with connecting to many local and remote databases and various tables and the same result keeps occuring. I've also tried with docker with even less luck as the vue map doesnt even come up

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.