1

Does anyone know what apt packages one should install for a postgres(8.4)/postgis(1.5) django (1.4) client on ubuntu 12.04?

All recipes seem to assume that I want to install the full postgres/postgis database server on the machine, but I have a external database server so I only want the packages that can connect to that.

For a full server I use:

apt-get install binutils gdal-bin libproj-dev postgresql-8.4-postgis postgresql-server-dev-8.4 python-psycopg2 python-setuptools
1

1 Answer 1

2

I've not tried it but try changing your apt-get to

apt-get install binutils gdal-bin libproj-dev postgresql-9.1-postgis postgresql-server-dev-9.1 python-psycopg2 python-setuptools

should do the trick. As its just the client its backwards compatible with older versions of postgresql.

postgresql-8.4-postgis is only available on lucid (10.04) the future releases (11.04) onwards use postgresql-9.1-postgis

http://packages.ubuntu.com/search?searchon=names&keywords=postgresql+postgis

EDIT:

apt-get install binutils gdal-bin libproj-dev postgis python-psycopg2 python-setuptools does the trick

6
  • Tried it, but postgresql-9.1-postgis also has postgresql-9.1 as an dependency. Is it possible to do this without that?
    – RickyA
    Nov 20, 2012 at 13:46
  • Thinking about it can't you just use python3-postgresql you shouldn't need any of the postgis stuff apart from on the server. Nov 20, 2012 at 13:50
  • Had a look if you just want the userland binaries, common files and documentation for postgis then you need to install postgis not postgresql-9.1-postgis Nov 20, 2012 at 13:59
  • Found it: apt-get install binutils gdal-bin libproj-dev postgis python-psycopg2 python-setuptools
    – RickyA
    Nov 20, 2012 at 14:31
  • Cool have updated my answer to reflect that. Nov 20, 2012 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.