6

In a single point dataset is it possible to get the labels to stop covering the symbols and be placed in a position that has white space automatically (i.e. without using data defined xy positions)?

enter image description here

Should look like

enter image description here this is from the SVG, edited in Inkscape.

The settings for the labels are as follows. All the point data shown is in a single dataset.

enter image description here

enter image description here

I have tried Cartographic mode as well.

Should something change in the symbol properties?

enter image description here

I am using 3.22.0.

2 Answers 2

6

For preventing label to get over your line layer just go to the labeling properties of your line layer (of course you could do that for any other layer you want to not be under label) then adjust your point layer label weight and the obstacle weight to get a result that suit you.

enter image description here

3
  • Yes thanks, I already have this as per my comment to sn1ks's answer. The issue here is preventing the labels from covering symbols in the same dataset.
    – GeorgeC
    Nov 16, 2021 at 20:57
  • 2
    I think your problem came from the point displacement renderer as the symbol are drawn in a different place than the real point position used by the labelling engine, you may try to increase the label distance factor (not sure of what this setting do but it's probably intended for this situation). You may also try to increase the label distance in the label setting
    – J.R
    Nov 16, 2021 at 22:38
  • The problem with this solution, is that if the line layer (in this case) also has labels, then setting this drop down to 'Blocking' will turn its labels off.
    – Theo F
    Jun 19, 2023 at 9:36
3

You should go to Layer properties -> Labels -> Placement Set label priority to low, click on "Settings" under Obstacles and give them the highest weight possible. Maybe this helps! enter image description here

1
  • 1
    Just tried but doesn't help. I want the labels to show, I just don't want them to cover labels in the same dataset. I assumed that Cartographic or Around Point with no Quadrant would move it to the most appropriate location. I also have a duplicate of the same dataset with Labels set as Obstacles but this didn't fix the issue.
    – GeorgeC
    Nov 16, 2021 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.