2

I am using QGİS 3.18 Zürich version.Trying to delineate a river basin catchment. Lately, I followed following steps:

  • Reprojected my DEMs
  • Used SAGA 'Fill sinks (Wang&liu)' tool and obtained Filled_DEM
  • Used SAGA Strahler Order tool and saw that I have 11 levels in my river basin.
  • Used raster calculator to have the optimum strahler level, which found to be 5. (used following function in raster calculater: Strahler_order=>8)
  • Used SAGA 'Channel network and drainage basin' tool to obtain flow direction, channels (as shapefile) and drainage basin (as shapefile).

Now I am trying to use SAGA Upslope Area tool to extract my focus drainage basin (because several adjacent basins are present, including my study area) and to perform further analysis on it. However, I obtain following error each time I try to run: "The following layers were not correctly generated."

Here are the inputs that I put for SAGA Upslope Area tool:

  • I am using QGIS Coordinate Capture tool to specify coordinates of the drainage outlet of my study area (I am clicking a point on the channels created as a shapefile)
  • I am typing the X and Y coordinates of the point on my channels (using the projected X Y coordinates)
  • Selecting the elevation as Filled_DEM
  • Selecting the method as Deterministic 8 However, not working at all.

Does anyone know where I am mistaken, and how can I fix it?

4
  • Do you have any NoData cell(s) within the 3x3 window around your selected outlet point?
    – Kazuhito
    Nov 18, 2021 at 12:06
  • I think I do @Kauzhito. I have several small white boxes in my study area, if they represent no data (sorry I am new to qgis). Should I fill these no data boxes first? Nov 19, 2021 at 6:31
  • I honestly don't know why but my old note says there was an issue related to surrounding NoData cells. Is it possible to move your outlet point slightly to somewhere more contiguous area?
    – Kazuhito
    Nov 19, 2021 at 9:58
  • I tried to eliminate no data cells, however not able to do it. Now I also start to think that maybe I am not typing the correct coordinates of my river outlet channel. That's why "upslope area" tool can not determine any river. Because, as I mentioned above, I am using "Capture Coordinate" tool and selecting the outlet point manually. Since I can not zoom in to my river channel (althoug I am zooming, river channel is not getting bigger), I can not select the river grid but selecting any point on my basin. I will try to find a way to correctly select the outlet coordinates and rerun it. Nov 21, 2021 at 14:10

1 Answer 1

0

I installed Fernaz version and did not work and most update as Lima as well. I have this problem for long time and tried and repeated all possible suggestions to solve it but did not succeed.To solve the puzzle Simply install two versions on your computer ad pi 3.14 version .. it works well with same data input of Fernaz prepare..dem..reproject..fill.. channel and drainage basin .. and continue with pi version and run upslope area... and again continue with Fernaz if you like or go back to more updated versions.. I think this helps with other bugs you may face regularly with QGIS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.