2

I want to use the QGIS plugin QuickOSM in QGIS 3 to extract the road network of a certain area.

enter image description here

However, when clicking run query, I get the following error message:

Network error with Overpass OSM API

I tried several keys, values and extents, but no combination is working. When I click on reset, it shows the following error:

An error has occurred while executing Python code: 

AttributeError: 'QuickQueryWidget' object has no attribute 'lineEdit_browseDir' 
Traceback (most recent call last):
  File "D:/Users/luschnei/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\QuickOSM\ui\quick_query_dialog.py", line 114, in reset_form
    self.lineEdit_browseDir.setText("")
AttributeError: 'QuickQueryWidget' object has no attribute 'lineEdit_browseDir'


Python version: 3.6.0 (v3.6.0:41df79263a11, Dec 23 2016, 08:06:12) [MSC v.1900 64 bit (AMD64)] 
QGIS version: 3.0.0-Girona Girona, 001c80b0c3 

Python Path:
C:/PROGRA~1/QGIS3~1.0/apps/qgis/./python
D:/Users/luschnei/AppData/Roaming/QGIS/QGIS3\profiles\default/python
D:/Users/luschnei/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins
C:/PROGRA~1/QGIS3~1.0/apps/qgis/./python/plugins
C:\Program Files\QGIS 3.0\bin\python36.zip
C:\PROGRA~1\QGIS3~1.0\apps\Python36\DLLs
C:\PROGRA~1\QGIS3~1.0\apps\Python36\lib
C:\Program Files\QGIS 3.0\bin
C:\PROGRA~1\QGIS3~1.0\apps\Python36
C:\PROGRA~1\QGIS3~1.0\apps\Python36\lib\site-packages
D:/Users/luschnei/AppData/Roaming/QGIS/QGIS3\profiles\default/python
D:/Users/luschnei/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins\qgis2web
D:\Users\luschnei\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins
P:/500/groupdrives/TCP/Aktuell/GIS Standortanalyse/GIS Models

Update: I now upgraded QGIS to the latest version 3.22 and updated QuickOSM. But now I get the following error message:

Overpass API : Download failed: Proxy denied connection

QGIS is installed on my work laptop, which might be the problem?

2
  • 2
    You are using QGIS 3.0.0, which is way too old and bugged. This version was released in February 2018 ! Upgrade your QGIS, do not stay on a .0 release, it's the most bugged version of a branch. By upgrading your QGIS to the latest release, let's say 3.22.1, you will be able to upgrade QuickOSM and this error will go away as well.
    – etrimaille
    Nov 23 '21 at 12:09
  • Okay, thanks a lot! I will try it out and update the post. Nov 23 '21 at 12:29
2
+50

Since QuickOSM is building the queries for you the queries are correct.
Your problem is you are working behind a proxy, meaning your network requests are being redirected through a funnel of sorts.

If you can access the web through a browser (Chrome\Firefox\Edge\IE\etc.) than the proxy is defined on your computer, and the error can come from one of two reasons:

  1. You need to define the proxy in QGIS
    1.1. Open the options window by going to Settings -> Options
    List item
    1.2. Go to the Network Tab and either make sure that you are using proxy for web access
    enter image description here
    1.3. If you are not using the default proxy, you need to ask your IT department what your proxy address is and set it under HttpProxy.
    enter image description here

  2. There is the option that your proxy server is blocking specific addresses, in which case you'll also have to ask your IT department to unblock the address of the server you are using which you can see in the plugin window at the Parameters tab.
    enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.