0

I configure my geoserver with WMTS (from Maptiler) and i would like to print using leaflet printing module but i can't to configure leaftlet to get capabilities from WMTS service and printprovider allways set to WMS its baseUrl.

I'm using last version of GeoServer but /pdf/info.json return error:

java.lang.NoSuchMethodError: 'void org.json.JSONWriter.<init>(java.io.Writer)'

I've tried to change a json library jar to old version but doesn't work. Also tried to install a 2.18.0 version but with error too.

Any ideas?

3
  • 1
    What is your Java version?
    – user30184
    Nov 25 at 22:00
  • 1
    Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Nov 25 at 22:09
  • Welcome to Geographic Information Systems! Welcome to GIS SE! We're a little different from other sites; this isn't a discussion forum but a Q&A site. Your questions should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. Please check out our short tour for more about how the site works
    – Ian Turton
    Nov 30 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.