6

Back in 2018, Google Maps start to get rid of mercator's projection in maximum zoom-out

So we can see the size of island (moreover those in poles) in it's original sizes

But today I try both in PC and phone, doesn't seem to work that way

Do they switch to previous decision? But why?

enter image description here

1
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Nov 28 '21 at 9:48
8

There are two settings that have to be right for the globe mode to work.

First setting is Chrome browser hardware acceleration setting:

Settings > Advanced > System > Use hardware acceleration when available > On

Second setting is globe mode in Google Maps:

  1. Move mouse over Layers selection icon in the lower left corner:

enter image description here

  1. Click on More:

enter image description here

  1. Enable Globe view:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.