3

The raster I am trying to reproject is found here https://psl.noaa.gov/data/gridded/data.gpcp.html, and it's the first one "Monthly Mean" (so you might try to do it yourselves).

Problem is that when I load it into QGIS, the coordinate system it's not -180 180 but 0 360. I tried every possible solution I could fine, even the very popular on this post: Reprojecting raster from 0 360 to -180 180 with cutting 180 meridian using gdalwarp but I can find no solution!

I tried to run the suggested command

gdalwarp -s_srs "+proj=longlat +ellps=WGS84" -t_srs WGS84 ~/0_360.tif 180.tif -wo SOURCE_EXTRA=1000 --config CENTER_LONG 0

but the raster doesn't change at all; it stays 0 360

How do I do this?


Here is a picture of my problem.

enter image description here

3
  • 1
    The raster I downloaded it from the site does not have a (correct) CRS. THe raster shows up on Null island.
    – Babel
    Dec 1, 2021 at 14:50
  • Actually I have no problem loading into QGIS, and I can extrapolate the data for the annual precipitation, but I cannot rotate my raster.
    – Simone
    Dec 1, 2021 at 14:57
  • 1
    What CRS should the raster have (the original that can be downloaded)?
    – Babel
    Dec 1, 2021 at 15:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.