Using OSGeo4W 1.5, when I go to add vector layer and select file type, navigate to my ESRI pgdb. I get a not a valid or recognized data source.

If I use the database type I get a page that defaults back to type odbc even though I just chose esri personal geodatabase in the previous dialog, it also requires host, database, port.

There seems to be no way to navigate to a file.

The help file is also blank and says new ogr database connection dialog.

Do I not have all the ogr support installed?

Has anyone looked into adding support for FME in QGIS? I use it to connect to many formats in all my other software.

1 Answer 1


It works from in QGIS 1.6 from OSGeo4W. Add vector layer -> File: c:\path\to\mdb

Are you sure it's a Personal Geodatabase (.mdb)?

  • not sure why I couldn't get it to work the other day. All good now.
    – Brad Nesom
    Dec 7, 2010 at 16:42
  • I wonder why the option to select esri personal db is in the other dialog (database)?
    – Brad Nesom
    Dec 7, 2010 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.