I do understand that this question (in some form or another) has already been aksed and answered on various forums, but i still cannot find a working solution.

I'm trying to import a .CSV file to QGIS with coordinates set with decimal points (XX.YYY - as suggested by various tutorials, such as this one). I'm using the "add layer -> add delimited text layer" function of QGIS. The CSV file loads in the dialog window, i check "semicolon" as the custom delimiter, select the appropriate X and Y fields for the coordinates, select WGS84 the Geometry CRS, the "add" button lights up, i run the process, the CSV file is added to the layers but the data isn't displayed. The "symbology" section of the "layer properties" dialog is also blocked.

I've also tried to re-format my latitude and longitude data to XX°YY'ZZ,WW" N/E but the results are the same.

Am i missing a step or I s my data formatting wrong?

Here's the .CSV file in question.


2 Answers 2


The problem is that some piece of software has rewritten your coordinates with thousand separators. E.g your first coordinate set is 45.698.648;9.036.160, I am pretty sure you wanted 45.698648;9.036160.

If this is your entire dataset, it should be possible to edit by hand - if it is a piece of a large dataset, you need to write some kind of script to do it or retrace the processing to before your coordinates were damaged.


you have to process your data on excel. For the latitude apply this formula: = REPLACE (F2; 7; 1; "")

and for longitude = REPLACE (F2; 6; 1; "")

to have this format:enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.