0

The current version which we use is GeoServer 2.10.0, which is a platform-independent installation. We want to upgrade this version to near latest version 2.19.x or 2.20.x. The plan is to take backup of data_dir of 2.10.0. Install a new version on a different port, test it with old version data_dir, if all OK, uninstall 2.10.0 and install the new version on the required port again.

Is it recommended to Jump from 2.10 to 2.19/2.20? Are there any major concerns to keep track of? Is there a better plan to upgrade/ Jump from 2.10 to 2.19/2.20?

1 Answer 1

0

Well, its not recommended but it's worth a try. If it doesn't work try the same procedure in 2 steps and if that doesn't work try it in 3 and so on until you catch up.

In future don't leave it so long to make upgrades.

1
  • Thanks, So by 2 or 3 steps, you mean. 2.10 -> 2.15 ->2.20 or 2.10 -> 2.14 ->2.17 ->2.20. Dec 22, 2021 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.