0

I'm brand new to QGIS and I'm trying to interpolate a set of X,Y,Z points but I'm not getting meaningful results. Below are the (Lon, Lat, Elev) points, their triangulation, and interpolation results (TIN interpolation).

I'm choosing the field corresponding to the elevation data for the interpolation attribute. All other options selected I believe are fine (e.g. linear, data extent, cell size). I've tried sever attempts with different settings, but I always get a crappy output and I don't know what the cause is.

A couple possible things...my fields are not named "x" "y" "z" or "lon" "lat" "elevation". They are titled "field_1" "field_2" "field_3", where again, I select "field_3" to be the interpolation attribute.

I don't know if the field names have to be something special?

Also, my longitude values are all negative, but I don't think that would matter?

Has anyone seen output like this?

What causes it and how do I fix it.

Point Distribution

Triangulation

Interpolation

6
  • Have you tried projecting your data to a coordinate system in meters, for example some one of the UTM zones, then try again
    – BERA
    Dec 25, 2021 at 12:27
  • That worked!! Does this mean QGIS does not support interpolation in a geographic coordinate system? Dec 25, 2021 at 20:52
  • What setting did you use with geographic CRS? What extent and output raster size (pixel size) did you set? Questions like yours should always come together with the settings you used - and, ideally, with a sample dataset.
    – Babel
    Dec 25, 2021 at 23:00
  • Settings? I can see on the bottom right of the screen it's in WGS 84 (EPSG:4326). Right click on the layer > properties > source....says the same thing. The extent I selected in the interpolation is the layer extent. I tried with other extents (e.g. screen) and I get the same result. Raster size gives ~1000x1000 pixels, which is the same as I did with UTM (which worked). I'm not sure what other settings w/ regard to the CRS I would need to adjust. If the projection worked, then I would think the base CRS would be valid? Dec 26, 2021 at 4:20
  • 1
    It seems you have resolved your issue, using a projected CRS. My remark was more in general, if you seek help, always provide the exact settings you made (parameters you used) to run a tool, best post a screenshot. And for others to be able to reproduce the error, it's extremely useful to provide test data. Otherwise, it's cumbersome if one first has to reconstruct the data that might still not correspond to what you have. So in the interest of getting helpful answers, provide as many relevant details as you can.
    – Babel
    Dec 26, 2021 at 10:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.