4

I am trying to plot a GeoPandas geodataframe as I always do. Now I am having a new pc when I try to plot my geodataframe using : gdf.plot() there is no plot displayed and I receive this message:

C:\Users\DELL\anaconda3\lib\site-packages\descartes\patch.py:62: ShapelyDeprecationWarning: The array interface is deprecated and will no longer work in Shapely 2.0. Convert the '.coords' to a numpy array instead

Does anyone have an idea about it?

3 Answers 3

13

( Answer for users who ended up here based on the title and just want to hide the error )

If you have acknowledged the error and do not want it to keep appearing, you can always ignore it using :

import shapely
import warnings
from shapely.errors import ShapelyDeprecationWarning
warnings.filterwarnings("ignore", category=ShapelyDeprecationWarning) 

1
  • Too bad they did not add their warnins to the official category of DeprecationWarning's
    – Alex
    Jan 8, 2023 at 7:23
2

I had the same issue. I tried uninstalling geopandas, earthpy and shapely afterwards I reinstalled geopandas==0.10, earthpy==0.9.4 and shapely==1.7.0. It worked for me.

0

Yes. It is almoast the same solution I have done. The error was due to non compatible versions of used modules. So I reinstall everthing with the latest versions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.