I was using QNEAT plugin for QGIS just fine after some very thoughtful recommendation on this web. The first time all went well, but I needed to redo it. Now when I try it I get an error.

I can use any QNEAT process and the same error occurs:

 Algorithm 'OD Matrix from Layers as Table (m:n)' starting… Input
 parameters: { 'DEFAULT_DIRECTION' : 2, 'DEFAULT_SPEED' : 4,
 GIS/Zástavba/Osídlenost 2020 Třebíč/Osídlenost 2020 Třebíč.shp',
 GIS/Infrastruktura/Highway Okres Třebíč
 EPSG-5221.gpkg|layername=Highway Okres Třebíč EPSG-5221', 'OUTPUT' :
 GIS/Docházka/QNEAT/qneat odm m2n 001.shp', 'SPEED_FIELD' : '',
 'STRATEGY' : 0, 'TOLERANCE' : 0, 'TO_ID_FIELD' : 'fid',
 hlavní Q GIS/VHD/highway bus stop Třebíč (5221).shp', 'VALUE_BACKWARD'
 : '', 'VALUE_BOTH' : '', 'VALUE_FORWARD' : '' }
 [QNEAT3Algorithm] This is a QNEAT3 Algorithm: 'OD Matrix from Layers
 as Table (m:n)' Traceback (most recent call last): File
 line 224, in processAlgorithm to_coord_list =
 getListOfPoints(to_points) File
 line 94, in getListOfPoints return [f.geometry().asPoint() for f in
 qgsfeatureiterator] File
 line 94, in <listcomp return [f.geometry().asPoint() for f in
 qgsfeatureiterator] ValueError: Null geometry cannot be converted to a
 Execution failed after 0.22 seconds
 Loading resulting layers Algorithm 'OD Matrix from Layers as Table
 (m:n)' finished

I am trying to do OD Matrix from layer as lines m:n.

All layers are the same as before when it worked. I have no idea what changed. I didnt do anything different.

Initially I followed advice in an answer provided for my previous question here: Average walking distance

  • 2
    You appear to have a null geometry in one of your inputs, you can use the QGIS tool check validity to verify which records these are and remove them/fix them
    – 15Step
    Jan 4, 2022 at 14:12
  • Thanks to you I just now realised that removing points with the Vertex Tool doesn't actually remove the point, only its geometry. Did not know that. It would seem I have done something in-between I forgot about. Thank you. Jan 4, 2022 at 20:22

1 Answer 1


User 15Step was right. I had some NULL geometries in my bus stops, because I tried to delete some and lazy me used Vertex Tool that only removes the geometry not the feature itself. I had to delete the points completely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.