0

I have successfully created a shortest path layer using QNEAT3. When I try and use the OD Matrix from layers as lines (M:N) i get NULL values.

My network layer is correct (as it works for shortest path) and has no errors (tested using Geometry Checker).

I have two other layers that contain a unique id and a lat and long column amongst other columns

The network is in CRS 27700 and the origin and destination are in CRS 4326. I have tried changed the CRS to either 4326 for network or 27700 for origin and destination and this doesn't work.

I have also tried using different Topology tolerances, but with no joy.

Below is the inputs i'm using for OD Matrix from layers as lines (m:n).

enter image description here

I'm using QGIS 3.16.2 Hannover and QNEAT 1.0.4

My Origin layer is as follows:

enter image description here

My Destination layer is as follows:

enter image description here

My dataset is much larger, I have used the Vector Selection/Random Extract to reduce the dataset for testing.

I have also followed the below tutorial, which worked fine:

https://www.qgistutorials.com/en/docs/3/origin_destination_matrix.html

4
  • You "have tried to change the CRSand this doesn't work". How / what did you do exactly? And what means "didn't work" - what did not work?
    – Babel
    Commented Jan 6, 2022 at 20:33
  • @Babel I changed the CRS in Properties/Source/Assigned Coordinate Reference System. By didn't work i mean i got the same results, NULL values for the 'costs'. I also tried changing it in the Project Properties. The Network values dissapeared from the maps when I changed them to 4326
    – RDC_Green
    Commented Jan 6, 2022 at 21:39
  • You "changed" the CRS in layer properties? Never do that! See: gis.stackexchange.com/a/392388/88814 and gis.stackexchange.com/a/383437/88814 - use Reproject instead of that: right click layer / export /save and in the export dialog, you can choose the CRS you want the layer to reproject to.
    – Babel
    Commented Jan 6, 2022 at 21:51
  • Thank you @Babel that has now worked.
    – RDC_Green
    Commented Jan 7, 2022 at 8:32

1 Answer 1

0

CRS 4326 is a simple lat -lon-System, not a projected one. Try saving this layer as a projected system ( crs 27700 ) and reload this new shape-file and now run your analysis again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.