1

I'm trying to merge three layers in QGIS 3.10.14. Each layer contains only points and displays correctly in my map view.

When I use the Merge vector layers menu option, I get the correct dialogue box. I then use the ... button next to the Input layers field and hit Select all in the resulting child dialogue box. However, when I hit OK, both that child dialogue box and the parent dialogue box vanish, with no new layer being created, and with no error being shown.

I tried looking at the log tab in the merge vector layers dialogue box to see if there's any output there. But nothing seems to show up.

Any ideas about where I can find more useful information on what's going wrong?

EDIT: I'm using the three layers of rail stations from https://septaopendata-septa.opendata.arcgis.com/

I've tried deleting all fields from all three layers before attempting the merge of the point layers, and that does not fix the situation.

7
  • If it is possible, delete all fields then merge. Or at least if you have some common id field, like FID, drop that. If you just want to keep the geometries I can post a pyqgis script I use to merge many layers
    – BERA
    Jan 9 at 12:33
  • Thanks to you both. I have tried removing the fields, and it does not appear to help. Which files would I edit in vim to combine the points?
    – Patrick
    Jan 9 at 16:32
  • I see 4 Data Categories in your link: Regional Rail Data, Trolley Data, Bus Data, and Highspeed Data. Where to go from there?
    – Pointdump
    Jan 9 at 16:52
  • I suggest updating to see if the bug is still present in a supported version.
    – Al rl
    Jan 9 at 17:03
  • 2
    An update: Upgrading to version 3.22.2 seems to have fixed the problem. If somebody makes that into an answer, I'll approve it. Thanks again!
    – Patrick
    Jan 9 at 19:06

1 Answer 1

1

Updating to QGIS 3.22.2 fixed this problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.