0

What is the best way to do this? I have two images that overlap about 20%, and they are 4 bands each. Same satellite provider, resolution, etc. so there's no apparent issue with alignment. Each file is a little under 1.5 Gb.

My method was was to build a VRT where I selected each of the two overlapping layers, unchecked place each input file into a separate band (I don't understand what this does).

Then I used GDAL translate to convert the VRT back into a GeoTIFF. After I did this, the file grew to 6.5 Gb. How is that possible if each separate file was < 1.5 Gb? All other parameters were left to default in QGIS.

4
  • What compression are you using? How are they overlapping, are the output not rectangular, nodata also consume space
    – BERA
    Jan 12 at 18:23
  • I'm not using any compression, just GDAL translate as it appears in QGIS. I'm not sure about your other point - all rasters are rectangular? There are some new NoData cells, but relatively very new ones.
    – hmnoidk
    Jan 12 at 18:33
  • Try selecting 'High compression' under Additional creation options. I mean if they overlap like this it is going to consume more space than if they overlap like the left image here
    – BERA
    Jan 12 at 18:36
  • Check also what compression, if any, is used in the source images.
    – user30184
    Jan 12 at 19:22

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.