I'm trying to create a shapefile with the extent of my raster so that it can be used as a mask to clip with. My shapefile has no datapixels along its boundary and is irregularly shaped.

So far I've put my raster into a mosaic dataset to create a footprint shapefile. However, on closer inspection this footprint shapefile cuts across valid pixels in my irregularly shaped raster image.

1 Answer 1


The default behaviour of raster to polygon conversion in ArcGIS is to simplify the output polygon geometry, which I guess is the reason why your extent is not exactly the same as the pixel that you have as input (see illustration from ArcGIS help below)

enter image description here

The solution is thus to uncheck "simplify polygon" hen you run the conversion tool. '''arcpy.conversion.RasterToPolygon(in_raster, out_polygon_features, "NO_SIMPLIFY")'''

Rem: I assume that your raster is reclassified before the conversion in order to have a single value for all valid pixels before the conversion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.