2

I have many raster layers that I want to merge and a lot of these layers have gaps of no data. These gaps are specified as "no data" as pictured in image 1

image 1

I then go to the merge raster tool and leave the advanced parameters as default (I've tried multiple variations by setting the input and output no data values to predefined values but always results in same issue).

I then get a merged raster layer that looks like image 2 with min values of -3.40282347e+38

image 2

If I understand correctly, the value -3.40282347e+38 is the same as "no data" - is this right?

I am able to update the symbology so that the raster layer now looks like image 3

image 3

However, when I look at the properties of the layer the no data value is reported as 0. This concerns me, as my actual no data values are -3.40282347e+38. I've tried reclassifying the grid values and saving as a new layer setting new no data values, but each time nothing works. The layer properties always says that the no data value is 0.

How do I get the no data value to be -3.40282347e+38? Or, better still, how do I merge the raster layers in the first place that the gaps of no data are maintained, avoiding all this post-processing?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.