0

I'm having some trouble clipping raster data. Once upon a time I was able to but recently I am met with an error message when I run the process. I've tried using all the options ie, clip by mask layer, clip by extent etc. If I change the "clipped extent" to save as file, name the file and delineate location, then unselect "open output file after running algorithm" the process seems to work but it doesn't save a TIFF file anywhere.

I've attached a photo of the errors I receive.

Why am I unable to do this?

enter image description here

4
  • 2
    Please always provide error messages as formatted text rather than pictures.
    – PolyGeo
    Jan 15 at 8:48
  • It seems you try to clop an XYZ-tile - a remote file. You can't use these for processing, they are just here gor visualization (basemap).
    – Babel
    Jan 15 at 9:43
  • If you want to clip for visualisation purposes only there are a couple of options. Make a polygon of the aea you wish to remain visible and then use Inverted polygon symbology. Or, in the Print Layout in the Map Item Properties there is an option called Clipping Settings - a small icon above the Main Properties dialog (last in the row). You can choose a layout shape item to clip with. These are both essentially just masks and will not alter the input data. If you are fortunate enough to find a WCS of the image (rather than the XYZ tiles mentioned by Babel), you can clip that.
    – Matt
    Jan 15 at 10:00
  • This question feels very similar gis.stackexchange.com/questions/388241/clipping-raster-error-4, in both cases the raster is coming from a service, not from a local file. Perhaps clip just does not work with service based data.
    – user30184
    Jan 15 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.