I am working in a 3D scene, and I have a vector line layer that is split thousands of times at 1 meter intervals. The layer has a range enabled so I can slide through the line for an animation. I created this layer in a 2D map then copied it into a 3D scene.

My problem (pictures included) is that I keep getting this weird back glow/ glitch coming from the line, it looks like it is glowing through the satellite imagery/ ground terrain, but at semingly random places, and not consistent.

Sometimes the glow shows up when I am working inside of ArcGIS Pro, and when I render and export the video, sometimes only in arc, and sometimes only in the exported video.

I have found that setting the elevation of the line layer in the properties box to be 2 or 3 meters above the ground terrain that it removes a lot of the problem, but not always.

I have tried troubleshooting with the following:

  • Changing the size of the line: no difference
  • Changing the quality of the render: no difference
  • More or less frames per second: no difference
  • Restarting the program, and my computer: no difference
  • New scene, and global and local scene: no difference, but sometimes it will create a new section with the glitch.

Does anyone have any ideas on what is causing this?

This is a screenshot of the rendered video, as the animated line gets closer to this back glow area the glow gets bigger. This is from a different rendered video when I was trying to troubleshoot.

  • Does the glow remain if you change the symbology of the line? Have ou tried it on another machine? Try running the repair geomtery tool on the layer you are using. Jan 16, 2022 at 21:54
  • I tried changing the size of the line, color, style, and they all still create the glow, but just with a different color. Tried the repair geometry tool but that did not work either.
    – HenryQ
    Jan 16, 2022 at 22:10
  • Are your base map and the layer in the same projection? Jan 16, 2022 at 22:33
  • Yes Sir. All of them are in WGS 1984 Web Mercator (auxiliary sphere)
    – HenryQ
    Jan 16, 2022 at 23:05

1 Answer 1


If these are lines in the 2D Layers group, and are "screen sized" (e.g. size in pixels) then it appears what you are seeing is a lower-resolution rendering of the same line, in the next rasterized tile.

Can you send this in as a BUG to Esri Support, along with a map package (mpkx) (from share->Map package) so that we can troubleshoot and potentially attempt to mitigate this bug?

To attempt to workaround: try changing the line to real-world sized (check the box on the display tab of layer properties).

  • one more suggestion: make sure you're on the latest release of ArcGIS Pro - IIRC we have put in some tweaks to LOD selection to reduce the appearance of this artifact in past releases. Jan 18, 2022 at 17:05
  • Great suggestions thank you. I will try them out soon and comment again if they worked.
    – HenryQ
    Jan 20, 2022 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.