0

I am trying to run a workspace from FME on ArcGIS attribute value checks, however, I am getting the below error message

"eReading file ERROR: A compatible ArcGIS application could not be found or is not licensed for Python Compatibility 'Esri ArcGIS Python 2.7' The workspace has Python Compatibility set to 'Esri ArcGIS Python 2.7', which requires an appropriate version of ArcGIS Desktop with Background Geoprocessing or ArcGIS Server. If ArcGIS is not required by this workspace, then update Python Compatibility to a non-Esri-ArcGIS Python. Otherwise, please install the required ArcGIS product, or if ArcGIS Pro already installed, update Python Compatibility to 'Esri ArcGIS Python 3.7'. To update this setting, go to: Navigator -> Workspace Parameters -> Scripting -> Python Compatibility Program Terminating Translation FAILED. Translation failed"

Not sure how to resolve it, I have tried changing the values of python both in workbench as well as a translator, I am using ArcGIS Desktop 10.8.1 and ArcGIS Pro 2.9 FME version is 2021.1.3.1

2
  • Add the FME version. Jan 18, 2022 at 14:17
  • did you resolve this... I spent a good amount of time with my FME vendor on it and still stuck
    – woodwa
    Jul 14, 2022 at 7:12

1 Answer 1

4

Be aware of the version compatibilities between FME & ArcMap / ArcGIS Pro.

  • For ArcMap 10.8.1 you need at least FME 2019.1.2
  • For ArcGIS Pro 2.9 you need at least FME 2021.0.2

If you want to use ArcMap (which is 32 bit) for the licensing part of FME (which is probably 64 bit), you need to install 64-bit Background Geoprocessing to fix the 32-bit vs 64-bit gap. I think this is the case as your log says:

A compatible ArcGIS application could not be found or is not licensed for Python Compatibility 'Esri ArcGIS Python 2.7' The workspace has Python Compatibility set to 'Esri ArcGIS Python 2.7', which requires an appropriate version of ArcGIS Desktop with Background Geoprocessing or ArcGIS Server.

If you want to use ArcGIS Pro to license FME, you need to change the Python Compatibility from 'Esri ArcGIS Python 2.7' to 'Esri ArcGIS Python 3.6+'. You can change this parameter in the Navigator on the left side of your screen. Workspace Parameters --> Scripting --> Python Compatibility.

This is all documented in the article https://community.safe.com/s/article/notes-on-fme-and-esri-versions-and-compatibility

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.