I have a question. My computer has been replaced with a new Xeon Workstation. Before that, I had a temporary workstation and had ArcGIS 10 on it. While I was waiting for the new workstation to be replaced, I was working on mosaic dataset and worked on several clipped rasters to mosaic them. When I got my new workstation back, I had to backup all of my datasets to external hard drive and then load them to the new computer. So when I bring the mosaic dataset up to my ArcGIS 10 on my new computer, all I see is black! Did I do something wrong when I made the backup or should I run some fixes?

Originally, what I did was that I had two NAIPs loaded from the ArcGIS server added them to my ArcMap and had a layer called mask to clipped the raster within the mask. I use them to mosaic them to created one mosaic file saved in Mosaic Dataset.

HELP !! I hope I do not have to re-do all the work again. Thanks for your feedback.

Thanks !


1 Answer 1


Most likely what happened is, in the process of moving the data from one computer to another, the paths to the imagery referenced in the mosaic dataset became invalid.

What you can do is repair the paths in the mosaic dataset. You can do this either with geoprocessing tools or an interactive dialog, as shown below. Be sure to increase the folder path depth enough to show all of the folder paths.

  1. In ArcCatalog, right-click the mosaic dataset and click Repair... This brings up the dialog shown below.
  2. Increase the folder path depth enough to show all of the folder paths.
  3. Enter the new correct paths in the New Path boxes
  4. Click OK

Repair Mosaic Dataset screenshot

In this example I have moved the referenced imagery from my Z: drive to my C: drive and updated the folder paths to reflect this.

  • Yes, I checked on that and it came out blank or nothing...
    Nov 27, 2012 at 0:31
  • What do you mean exactly?
    – blah238
    Nov 27, 2012 at 0:35
  • When I use the Repair Mosaic dataset dialog box (picture shown above) It showed nothing..so My thinking is that the pathnames is gone. Or should I go back and check it again ?
    Nov 27, 2012 at 0:47
  • Did you increase the "Folder Paths Depth"? Try a large number like 50 to be sure.
    – blah238
    Nov 27, 2012 at 0:49
  • Ok, will check on that tomorrow morning when I get in to work. Thanks
    Nov 27, 2012 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.